We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 15:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 15:00 UTC
Identified
This disruption appears to be related to the ongoing https://www.cloudflarestatus.com/. We are working closely to mitigate the impact and will provide updates as soon as more information becomes available.
Posted Nov 18, 2025 - 14:10 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 13:37 UTC
Investigating
We are currently experiencing elevated errors again, impacting logins and access to our application. Our engineering teams are actively investigating the issue.
Posted Nov 18, 2025 - 13:22 UTC
Monitoring
NA10 environment experienced elevated errors affecting logins and application access between 11:30 AM and 12:10 PM UTC. The issue has now been resolved, and we are monitoring the system to ensure continued stability.