EU3 Performance Degradation
Incident Report for Replicon
Resolved
This incident has been resolved.
Posted Apr 01, 2024 - 06:00 UTC
Investigating
We're experiencing a performance degradation that may be impacting customers. Our engineering teams are currently looking into the issue. We will post updates as soon as we have more information.
Posted Apr 01, 2024 - 05:20 UTC
This incident affected: eu3.