NA12 - Performance Degradation

Incident Report for Replicon

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 18:54 UTC

Update

We are continuing to investigate this issue.
Posted Mar 24, 2026 - 18:52 UTC

Investigating

We are observing intermittent elevated error rates that may prevent users from viewing or updating their timesheets. Our engineering teams are actively investigating the issue and will provide further updates as more information becomes available
Posted Mar 24, 2026 - 18:51 UTC
This incident affected: na12.